Upgraded iPhone, sprocket app can’t find printer

Posted by Tiredmomofold on

After iPhone change (is all I can figure) my sprocket app can’t find the sprocket printer. I have used this printer for a year or more for my daughter’s school reports. Usually it just connects up when I turn it on. The Bluetooth is on. The sprocket is listed under the list of items and it is showing connected. However when I click on sprocket and chose the item to print, it tries to find the printer and says it can’t. It says it is looking but can’t find it. It says it maybe an earlier version and then says to click that. When it click that it shows select an accessory, 4 lines and nothing else. I installed the app on my daughter’s iPhone 6 and it is doing the same thing. I reset the printer with a needle. I restarted my phone. She went ahead and drew the pictures because it was midnight.  Any help would be appreciated. I have iPhone XR but I can’t think that matters because it did the same thing with her iPhone 6. The previous level it worked great with was iPhone 7. Totally frustrated. 

Older Post Newer Post


  • Thank you!  You are smart!  I had installed it new on my daughters phone and it still didn’t work. So after multiple things I finally called HP and they said exactly the same thing: uninstall app and then install it and that will fix it.  They said it fast and in the first 10 seconds of my call. Lol. I guess it’s a known issue and they figured out that was the fix. You should work for HP!  Thanks so much. Problem solved!

    Tiredmomofold on
  • I had the same issue until I uninstalled and reinstalled the sprocket app. Now it works. 

    Usernamexxxxxxx on

Leave a comment

Please note, comments must be approved before they are published