Sprocket malfunction after 1st use - not found or printing blank pages

Posted by akselsoft on



I purchased my Sprocket in the summer and when I got it, I printed from it  (iPhone 6S) once and it worked fine. I pulled it back out recently to print some pictures and it prompted to connect but then when trying to print said it wasn't connected.


I followed the steps on the site for resetting the printer. Each time, it takes about four attempts before it connects via Bluetooth to the device. Thinking it may have been the paper, I put the paper in from a brand new pack of HP paper. I turned it on. It didn't find my device but started printing. It started by printing the blue sheet and then kept printing blank pages.


I read on the forum here that this sometimes happening and the printer needs to be reset. So I did this again. I left it overnight charging so it had a full charge. I removed the Bluetooth connection and restarted my phone. I then turned on the sprocket (it turned white). It said it wanted to connect and connected. But within the Sprocket app, it said "not connected". Thinking it was the app, I deleted the app and reinstalled it from scratch. 


It connected to my phone but then again when it tried to print, it said nothing was connected. I've attached pictures to show what is happening. I recorded  a video because it continues TRYING to print even when there's no paper in the device.


Needless to say, this is extremely frustrating. IMG_1657.pngIMG_1656.pngIMG_1656.png


Any help or can we open a support ticket?



Older Post Newer Post


  • This happens to me too! It is indeed frustrating.

    Runswscissors59 on
  • Hello @akselsoft -   Sorry to hear about the issues you encountered with connectivity through the sprocket app. It sounds like you need to “update” your version of the Sprocket iOS app, then attempt a firmware update on your device.  You should be running app version 2.03.1 on your phone. A more detailed set of instructions for how to resolve this issue are contained in the support document here: https://support.hp.com/us-en/document/c05300073 You’ll likely have to forget/re-pair your device a couple times to make that initial connection, but after updating firmware, the connectivity should be much more reliable. Hope that helps…

    *I am an HP employee*The comments above represent myself and do not reflect the opinions of HP.If my post solved your issue, please click “Accepted Solution” on the post . To show appreciation for my help, please click the “Thumbs Up Icon” below! Thank you 🙂

    Spectre_Envy on

Leave a comment

Please note, comments must be approved before they are published