Sprocket 200 won't pair after firmware update

Posted by HoAnBu on

About three hours ago, I turned on my Sprocket to edit & print a photo.  The Sprocket app told me there was a firmware update, so I let it load.  Mistake #1


I then selected and edited my photo, and sent it to print.  Twenty minutes later, it still hadn't printed.


Looking at the app, it said it wasn't connecting to the printer.  I checked my bluetooth, and although it was on, it wasn't connecting to the Sprocket.


I then checked the community for solutions.  Mistake #2.


I turned off Bluetooth, turned it back on.  No joy.


I turned off the phone, turned it back on.  No joy.


I turned off the Soricket, turned it back on. No joy.


I did a hard reset on the Sprocket. No joy.


I then uninstalled the Sprocket app.  Mistake # 3.


I then downloaded and tried to reinstall the Sprocket app.  Reinstall failed.  Tried again.  Failed.  Tried a third time, and it finally worked.


I then tried to add my Sprocjet to the app.  But, although it sees the Sprocket - my Sprocket name is listed as a device to select - it connects, but fails to pair, giving me a pop-up window that says  "oops, something went wrong... blah, blah, blah..."


I now have a useless Sprocket.


I have tried all the fixes several times prior to uninstalling - turning off/on phone, turning off/on Sprocket, hard resetting Sprocket, turning off/on bluetooth .


My problem now is I don'the even have a working app, because I can'tell get past the "add Sprocket" step.




Older Post Newer Post


  • After everything, I thought of reading the pdf manual on the product. I found that the Hard Reset button was illustrated and realised that I was not pressing the correct one. I followed the instructions again and it worked!! I’m back to printing now and all seems stable. Sorry if it still doesn’t work for you.

    Farahat on
  • I had to unpair the Sprocket, and remove the app.  I had to do that several times.  Eventually, after the third or fourth time I deleted the app from my phone, and reloaded it, it finally paired correctly.  However, it never really fixed the problem, because about every third or fourth time I use the Sprocket, I have to go through all of that again.  What should be a two minute job of printing one photo, ends up being a two hour job of repeatedly trying to pair the Sprocket, deleting the app from my phone, re-downloading the app, trying to re-pair the Sprocket, rinse, repeat two or three more times.  I am now at the point where I haven’t actually even bothered printing a photo on the Sprocket for several months.  It’s actually easier to just toss the photo in dropbox from my phone, then print a paper copy from my computer, and use that in my journal.  Sad, really.

    HoAnBu on
  • Hi. I have the exact same issue. Out of the box sprocket paired easily and I managed to print my first photo. Then the prompt for firmware update. So I updated my firmware. Right after that I am unable to pair with my printer. I even tried a different mobile to pair up but it could not detect the printer even though it is on. I have also tried all the steps suggested. Printer is not detectable by any device even though it is on a fully charged. Guess I have to return it for an exchange. And maybe HP should remove that firmware update totally.  

    Farahat on
  • The same thing is happening to me. Did your problem get resolved? 

    Rachael7587 on
  • @HoAnBu,
    Thanks for responding again.
    There is a difference between a hard reset and a factory reset on the printer.
    Factory Reset: Factory resets are generally done to remove the data entirely from a device, the device is to be started again and requires the need of re-installation of the software. The factory reset makes the device function again in a new form. It cleans the entire system of the device. It is probably done at the time of updating to a new version of the device’s software.
    Hard Reset: When a device does not function properly, it means the setting in the device needs to be changed, so only that part of the device is reset, or rebooted in the hard reset. It clears all the memory associated with the hardware and updates the hardware with the latest updated version. After the hard reset, the CPU or the processor restarts the application.
    However, as I mentioned in my previous post. It sounds like a printer issue. 
    Please contact HP support for service options.
    Take Care! 🙂

    A4Apollo I am an HP Employee
    A4Apollo on

Leave a comment

Please note, comments must be approved before they are published