Ink Cartridges are not inserting properly in sprocket studio

Posted by SEF142 on

I have just purchased a sprocket Studio and have tried inserting 3 ink cartridges and each time I try to print I get an error message to change ink cartridge. When I remove the cartridge the film gets damaged and so is unusable. Please help as I have just wasted 3 perfectly good cartridges and not one photo printed. 

Older Post Newer Post

1 comment

  • @SEF142, Welcome to HP Support Community!
    Looks like a hardware failure. Refer to the User Guide to find any help.
    If the issue persists, please reach out to the HP Support in your region regarding the service options for your printer.
    Hope this helps!
    Please click “Accepted Solution” if you feel my post solved your issue, it will help others find the solution. Click the “Kudos/Thumbs Up" on the bottom right to say “Thanks” for helping!

    TEJ1602 I am an HP Employee
    TEJ1602 on

Leave a comment

Please note, comments must be approved before they are published