HP Sprocket 200 printer will not power up. completely dead.

Posted by ClaireChristine on

HP Sprocket 200 printer.  Completely dead.  Used only 3 times when purchased.  Not used in approx year and a half.  Will not charge up.  Red light flashing.  Power on button produces nothing.  I uninstalled the app and re-installed but app does not recognise sprocket.  States it has searched and nothing in the vicinity. I tried using a pin to press the little circle on the side of the sprocket and also the little circle inside the sprocket to no avail.  The sprocket unit itself just seems to be completely dead.  Would love any assistance please.  

Older Post Newer Post

1 comment

  • Hi @ClaireChristine
    Welcome to the HP Support Community. 
    Please try these steps - Blinking Red Charging Indicator Light
    If the issue still persists, I’d suggest you Contact HP in your region regarding the service options for your printer.
    If you are having trouble navigating through the above options, it’s most likely because the device is out of warranty. If yes? please send me a private message with the region you are contacting us from. Check next to your profile Name, you should see a little blue envelope, please click on it.  
    Have a great day! 
    Please click “Accept as Solution” if you feel my post solved your issue, it will help others find the solution.
    Click the “Kudos, Thumbs Up" on the bottom right to say “Thanks” for helping!

    Asmita I am an HP Employee
    asmita6658 on

Leave a comment

Please note, comments must be approved before they are published