Connection problem with HP Sprocket

Posted by Paomiao on

I have tried connecting my old sprocket multiple times to my new iPhone 11 pro max  and it doesn't seem to be connecting to the app. It connects to my Bluetooth settings, but as soon as I go to print something, it says that it needs to be connected to the app and that it can't find the printer. So I dosconnetcted it from the new phone, connected it to the iPhone 8 of my wife and it works perfectly.  Why? Is there any issue with iPhone 11. The app is updated to the latest version.

Many thanks.

Older Post Newer Post


  • Hi I had tried all of those and it didn’t work. However I deleted the app and reinstalled the app and it connected with no issues and I was able to print with no issue. 

    JadeHR on
  • @JadeHR, Welcome to HP Support Community
    I see that you have connectivity issues with the HP Sprocket Photo Printer and your iOS device. To be able to assist you better, I’d like to know the following-

    Have you tried connecting the sprocket to any other device? If yes, you need to forget the printer on all the devices it was connected previously.
    Have you tried removing the printer from your Bluetooth devices and re-adding it? If no, please do it.
    Update your iOS device.

    Restart the devices and try again.
    Hope this helps! Keep me posted. 
    Please click “Accepted Solution” if you feel my post solved your issue, it will help others find the solution. Click the “Kudos/Thumbs Up" on the bottom right to say “Thanks” for helping!

    TEJ1602 I am an HP Employee
    TEJ1602 on
  • I have the same issue (iPhone 11 pro and sprocket 100) and have tried all of the suggested methods to make the sprocket connect and they don’t work. It will connect to Bluetooth but doesn’t seem to be found when on the actual sprocket app. 

    JadeHR on
  • I have this same model, and this same issue. 

    Pam938 on
  • I have the exact problem as the others. App does not find Sprocket even though connected to my Bluetooth. Have done the reset and all other advice. Can’t upgrade firmware as it is not listed in the hamburger. Helpcalled support – no help at all. No solution. 

    Pam938 on

Leave a comment

Please note, comments must be approved before they are published