Brand new sprocket won’t turn on at all

Posted by Sparky536 on

Just got a brand new sprocket plugged it in for the past 5 hours but still won’t turn on, when I plug it in red light comes on for about 1 minute then goes off

Older Post Newer Post


  • Hi, my brand new sprocket 200 has been on charge with a flashing red light for nearly three hours and will not turn on.
    Tried the following:
    Waiting 90mins to charge, pressing on button, reset button, leaving off charge and trying all again.
    There has not been a green or white light at any point.
    I’m incredibly disappointed in this product.
    Please advise whether I need to return for a refund.

    Sam on
  • @Sparky536, Welcome to the HP Support Community!
    To assist you better, what model HP Sprocket are you using?
    Refer to this document to know how to find the Product Name or Product Number.
    Try Resetting the Printer and check if it works

    Turn on the printer.

    Locate the reset button near the charging port.
    Figure : Locating the reset button

    Gently insert the straight pin into the reset button access point, and then press the reset button for 3 seconds.
    The printer resets and turns off.

    Turn on the printer.

    Let me know how this goes.
    If you feel my post solved your issue, please click “Accept as Solution”, it will help others find the solution. Click the “Kudos/Thumbs Up" on the bottom right to say “Thanks” for helping!

    KUMAR0307 I am an HP Employee
    Kumar0307 on

Leave a comment

Please note, comments must be approved before they are published